Whatever your operating system, you will need to install Scilab first. The new version (1.7.6) of XMLlab needs Scilab version 5.4.1, which is available for Windows and Linux at the Scilab's site. Unfortunately, XMLlab cannot work under Mac OSX because the Scilab Tcl/Tk module is not available on this platform.

Plotlib : XMLlab still depends on a specific version of the Plotlib. When XMLlab is installed from the ATOMS module manager in Scilab, then this library is automatically installed. However, if you plan to make an offline installation of XMLlab, you need to install this library yourself:

1 - Download the archive on the plotlib page on Scilab forge at the following url:

2 - Install the package from Scilab's command line :
--> atomsInstall

Downloading and installing XMLlab

All the versions contain XMLlab, this following instructions to install it, and some examples.

XMLlab is also available through the ATOMS module manager within Scilab, but until the new version is packaged by the Scilab team, you need to do an offline installation:

1 - Download one of the zip archives below (hosted by the Scilab forge)

2 - Install the package from Scilab's command line (for example the Linux version):

--> atomsInstall     



Installation of the XMLlab Webserver feature (Linux version)

See the installation details in the file install.pdf.